fluidasserts.lang.php module

This module allows to check PHP code vulnerabilities.

fluidasserts.lang.php.has_preg_ce(php_dest, exclude=None)

Search for preg_replace calls with ‘/e’.

Parameters
  • php_dest (str) – Path to a PHP script or package.

  • exclude (typing.Optional[list]) – Paths that contains any string from this list are ignored.

Return type

fluidasserts.Result